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Foreword
The Expert Series  10.0: Quick Start Guide document provides an introduction to 
the  basic  3D  model  handling:  triangle  model  repair  and  model  splitting  with 
3Data Expert, 3Data Expert Lite  and Dimensions Expert software products for 
Additive Manufacturing. 
Expert  Series  10.0  is  a  64  bit  implementation  allowing  you  to  handle  huge 
models for Additive Manufacturing. This and the ability to connect directly to AM 
processes via new user defined plugins make your everyday data preparation as 
easy as you can imagine!
There are two simple lessons and it should not take more than 15 minutes to go 
through the examples.  The first  lesson fixes an erroneous STL model  for  3D 
Printing using the Auto Repair process available with Expert Series 10 software.
The second lesson  describes methods to split  and combine STL parts for 3D 
Printing. Large parts must be split and pins have to be added to be able to attach  
the  manufactured  parts  correctly  with  Expert  Series  software.  The  split  and 
repaired data can be transferred directly to downstream AM processes through 
new plugin interface. 
DeskArtes Expert  Series  software  suite  consists  of  several  products  targeted 
from home and DIY use to education and professional Additive Manufacturing:

– View Expert is entry level tool targeted for viewing, verifying, dimensioning 
and communicating  3D geometry information.  Free View Expert  allows 
you  to  input  triangle  models,  create  consistent  topology,  check  errors, 
orient normals and output STL data for 3D printing without any cost.

– 3Data  Expert is  professional  tool  for  preparing  3D models  for  Additive 
Manufacturing and Simulation applications. There are several commands 
for manipulation of both 3D surface models and 3D faceted models. Thse 
commands include surface triangulation, STL verification and repair, STL 
offsetting,  splitting,  connecting,  decimation,  smoothing  and  boolean  as 
well as STL coloring and texturing. Basic supports can be generated for 
both Stereolithography and metal processes. 

– Dimensions Expert is a simple, economical and user friendly tool for STL 
repair and splitting for machines with a smaller build area. 

– 3Data  Expert  Lite  adds  primitive  generation,  boolean  and  3D  markup 
commands to Dimensions Expert functionality for connecting STL models 
as well as adding/engraving 3D text on STL parts.

– Sim Expert is  a dedicated tool  for  preparing 3D models for  Simulation 
applications,  with  triangle  count  reduction  and  triangle  aspect  ratio 
improvement functions.
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– Design  Expert is  a  tool  for  free  form  conceptual  design  for  jewelery, 
ceramics and conceptual design.
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Lesson 1 – Fully Automatic STL fixing 
Welcome to Expert Series 10.0 tutorial Lesson 1. Expert Series 10.0 is a 64 bit  
implementation allowing you to handle huge models for Additive Manufacturing 
(AM) and Simulation applications. But let's start with more simple models. 
This lesson shows you how to fix an erroneous STL model for AM using the 
automatic  tools  with  3Data  Expert,  3Data  Expert  Lite  or  Dimensions  Expert 
software. Before starting the lessons please make sure you have received and 
installed the software evaluation license from DeskArtes. If you do not have a 
license yet, it is very simple to request a license. First start the program from the 
desktop icon:

Then go to  the  Program licenses dialog through  Help >  Licenses command. 
There you can find the Send license request by email button. Press it and it will 
open your favorite email application to send the license request to DeskArtes.

Page 6



Expert Series 10.0: Quick Start Guide 

You will receive the 30-day evaluation license within 24 hours. 
When the license  arrives, press Install license code button and Copy/Paste the 
license string into the input field that appears:

Then press OK as requested to accept the license. Finally,  restart the software. 
Now you are ready to go ahead with the lessons!

Auto Repair process for STL files

When inputting a triangulated model into Expert Series software, an automatic 
analysis and repair process is started. In normal everyday use you can verify and 
correct most of the models using the Auto Repair process. Now we will show how 
the Auto Repair process works. 
First open the dino-connected.stl file in the Tutorials/GeomFiles directory with 
the File > Open command. Make sure the Files of type is STL:
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Press Open to bring the model into the software. You will be prompted for the 
units, accept the proposed units Millimeters:
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Press OK to continue and you will be prompted for the Operation Mode. 3Data 
Expert has four main operation modes: Fix Model, Paint & Texture Model, Print  
Preparation, and  View Model mode. The different modes are used for specific 
tasks:

● Fix  Model takes  you  to  automatic  model  verification  and  repair,  and 
contains shortcuts to the main tools used for repair work; 

● Paint & Texture Model displays the tools for painting and texturing. These 
tools check the model for errors and set it to “what you see is what you 
get” display color mode (this mode is not available with Dimensions Expert 
or 3Data Expert Lite software products); 

● Print Preparation shows tools for model manipulation, such as hollowing 
and splitting. These tools also check the model for errors; 

● View Mode minimizes the Operation Mode window and allows you to view 
the model and then return back to Operation Mode selection when clicking 
the minimized window again. 

The normal way to begin repairing a model is to start with the Fix Model mode. 
To start fixing  press the Fix Model button in the Operation Mode dialog now. 
Expert Series will begin automatic model verification (Fix Model > Verify Shells  
command). The screen is erased and a progress bar appears. When the analysis  
is ready, a Model status message box is displayed
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The message indicates that there is one verified shell, which also contains errors. 
The display shows red Gap curves through the surfaces. Gaps are an error type 
you must fix during the repair process. 
Press  the  OK  button in  the  Model  status dialog.  You  will  see  the  model 
structure in the  Model Tree on the left-hand side of the graphics area (see the 
image next page). The model is divided into separate shells during verification. In  
this case we only get one shell (1. dino-connected (Verified)). 
The shell has errors (i.e. gaps), which is indicated by the red icon        in the 
Model Tree (correct shells would have green icons) . 
On the right hand side of the graphics area you will see the Tools Window.  Fix 
Model Tab on the Tools Window provides shortcuts to the commands available 
for repair,  like Repair Shells,  Offset,  and Fill  Gaps commands. The  Help text  
window at  the  lower  part  of  the  Tools  Window also  contains  information  for  
required repair actions. We will learn more about these in the Tutorials, now we 
will follow the Auto Repair process. 
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Auto Repair  is the best path to follow when repairing everyday models.  Auto 
Repair will attempt to fix all shells with errors in the Model Tree. Especially when 
you only have one shell, like now, you should always try Auto Repair first.  Press 
the Yes button to initiate Auto Repair now.
When Auto  Repair  is  started  each  shell  is  run  through  the  automatic  repair 
command (Fix Model > Repair Shells  command) using automatically calculated 
parameters.  For each shell,  a progress bar shows the progress of the repair. 
After the Auto Repair process  the following message is displayed: 

Press OK and you will now receive the final status report:
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Press the OK button to close the  Model status window,  containing the final 
status  report.  A  Tip  Window with  useful  tips  on  viewing  and  selection 
mechanisms is also displayed after Auto Repair. After reading the tip you can 
Close the window:

During the Auto Repair, Expert Series fills all gaps and removes non-manifold 
triangles (overlapping triangles, multi-edge triangles, duplicate triangles, triangles 
having less than three neighbors, etc.) from the model. When you want to learn 
more about triangle errors, please see the “Triangle errors” page in the Online 
Help chapter “Handling Faceted Models”. The dino-connected.stl model only has 
simple errors, like inverted triangles and gaps, which are all fully repaired during 
the Auto Repair process. The model is now correct and can be printed (or taken 
into simulation softwares), as is indicated by the status information in the Help 
text window below the Fix Model Tab on the right hand side of the screen. 
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Basic viewing commands

You have just fixed your first  model with Expert  Series software.  Now try the 
following commands to become familiar with viewing operations. 
Note that the commands below do not alter the model’s true 3D coordinates. 
They only alter the eye-point location: 

● Rotate the model on the screen by pressing the middle mouse (MMB) and 
moving the cursor. MMB rotation is always available.  Left mouse button 
(LMB)  rotation is available most  of  the time except  when working with 
painting, texturing, curve editing, and transformations (LBM is mostly used 
for selecting objects as shown later).  

● Rotate the model around a selected surface point by pressing the  right  
mouse button (RMB) and moving the cursor. A blue cross indicating the 
rotation middle point appears on the part surface if the cursor is on top of  
the model when the RMB is pressed. 

● Pan the model by dragging with the  Shift +  MMB (or  LMB  most of the 
time) (Shift + MMB means pressing the Shift key and dragging with the 
mouse).

● Pan with rubberband by dragging with Shift + RMB.
● Zoom in/out by rotating the mouse wheel.
● Zoom in/out with Ctrl + MMB (or LMB). 
● Zoom to box with Ctrl + RMB. 
● Hide all by pressing the       icon with LMB (or F5)
● Show all by pressing the        icon with LMB (or F6)
● Fit the model by pressing the       icon with LMB (or F7).

The main viewing command icons reside in the Viewing Toolbar:

Try them out now. The tooltips provide a short description of each icon (let the 
cursor remain on top of the icon for a couple of seconds to see the tooltip).  
Please  note  that  some  icons  will  perform  slightly  different  operations  when 
pressed with RMB or LMB as seen in the tooltip image:
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Also, the Viewing Planes toolbar allows you to select any projection direction as 
the viewing direction (try both LMB and RMB clicks):

Try also Clipping functionality through 
the  Clipping  Tab  to  look  inside  the 
model. The Clipping Tab is opened with 
the           icon. The clipped area can be 
displayed  with  different  ways,  like  with 
wireframe or transparent. 
Clipping also enables to extract real time 
slice  information  on  the  model.  Real 
time  slices can  used  to  visually  check 
the  model  quality  or  be  copied  to  the 
Model  Tree  for  internal  model 
dimensioning with the  Edit > Save Clip 
curves command. 
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Selecting objects

On the left hand side of the Expert Series software window you can see the 
Model Tree tab.

This tab tells you the current contents of 
the program database. With this 
example you can see one shell (aka 
node, group) 1. dino-connected 
(Repaired). The node 1. includes the 
correct dino model, as indicated by the 
green       icon with the shell. The 
(Repaired) text describes the last 
command run on the surfaces, which in 
this case is repair. 

 

If you click the +-icon at the shell 1. it 
will open and display the separate 
triangle surfaces the dino model is 
made of. During the repair process the 
model is subdivided into separate 
surfaces along sharp edges. Triangle 
surfaces are indicated by a yellow 
triangle       icon and the last operation 
name, i.e. 1. Repaired for the first and 
largest area triangle surface in the 
model and so forth. 

You can select objects at different levels either directly from the Model Tree with 
LBM  click  or  graphically  from  the  display  area.  For  example,  the  surface  4 
selected from the Model Tree corresponds to the sole of the front right leg of the 
dino model. This is indicated with highlight and green bounding box around the 
selected surface in the display area:

Different objects can be selected also graphically from the display area with LMB. 
On the  right  hand side  of  the  screen you  can see the  Tools  Window which 
includes the Selection mode icons. 
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The Selection mode icons allow you to 
set the graphical selection level to  All,  
Shell,  Surface  or Gaps.  The  default 
mode is shown in the image right and it 
is  the  Shell level.  If  you now click on 
the dino model on the screen with the 
LMB  the  shell  1.  dino-connected 
(Repaired) will be selected in the Model 
Tree. 
Generally,  the Tools Window contains 
handy  shortcuts  to  the  available 
commands  in  the  selected  Operation 
Mode as well as  Help text window for 
the selected object or for the command 
in progress. 

With Expert Series software you normally should select an object and then run 
the desired command to it, as seen in the next lesson. 
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Lesson 2 - Splitting and Combining STL
One of the most common tasks with 3D Printing is to split a large model into  
smaller pieces to fit into the build area. This lesson shows you how to split large 
STL models for Additive Manufacturing. Sometimes building a very tall  part is 
more expensive than building two shorter parts simultaneously. Also, the building 
area may not be large enough for a very big part. Correct joining of the split parts  
is ensured by adding guiding pins to the models.

Splitting the dino model

Start  by  inputting  the  DeskArtes  geometry  file  DinoOk.3de in  the 
Tutorials/GeomFiles directory. Give the File > Open command. During the input 
you are prompted if the previous  dino-connected model should be stored into .
3de (DeskArtes proprietary format) file. You should press No when prompted for 
it and continue to the file Open window. Set the correct  File of type (.3de) and 
select the DionOk.3de file for input. 

The file includes a correct triangulation for the familiar  dino model. You should 
accept the proposed units and  go directly to the  Print Preparation  mode by 
pressing the 
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button in the Operation Mode Window. You should see the following dino model: 

with the Print Preparation Tab on the right hand side of the screen.

The  Print  Preparation  Tab  gives 
shortcuts  to  the  mostly  used  print 
preparation  commands,  like  split, 
connect, add lap joint, hollow, offset and 
drain  hole.  The  Help  Text  provides 
context sensitive help to the commands. 
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Select node 1. dino (Repaired) by clicking it with the LBM in the Model Tree. 
Before  the  splitting  we  must  take  a  correct  view  to  the  model  because  the 
splitting plane is generated by extruding a user defined split polygon away from 
the  viewer.  With  3D  Printing  the  correct  way  normally  is  to  split  the  model 
perpendicular to the z-axis to make the part lower. Thus, take a view from the x-
axis direction with       + LMB (or View > Ortho View > Front (+X)).

The splitting is started with command Print Preparation > Split or with the 
command shortcut in the Print Preparation tab:

The system prompts you to take the correct view direction if no yet set: 

When the view is correct you can  press Continue or Cancel to quit. You may 
hide this window permanently if necessary by ticking the “Don't show this window 
in the future”. 
The Split STL parameter dialog appears. The system asks you if you wish to use 
a Polyline (linear), Curved split line or Coordinate value. We will select Polyline 
for this exercise: 
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After  pressing OK the system goes into the curve edit  mode where you can 
define the shape of the splitting surface.  Press OK now to start the curve edit 
mode.
In the curve edit mode you can draw the shape for the splitting surface. Draw a 
horizontal line by giving two points with the LMB clearly outside of the dino 
model as seen in the image below: 

The curve editing is finished by pressing the RMB (or ESC key to cancel). When 
RMB is pressed the model is split along the plane defined with the polyline. After 
a while the result is available in the Model Tree. You can select the upper part  
with LMB click on the shell 1. a-dino (Split) to highlight it. 
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The two halves are named with  a- and  b- prefixes to distinguish between the 
shells above the split line and below the split line.

Creating the pins

The separate parts of the model could now be positioned and stored into .stl files 
for 3D Printing. However, the precise joining of the ready parts would be difficult 
or impossible. To be able to position the parts accurately we shall add pins in the 
models to connect them accurately together after finishing the build.
First we will locate the necessary primitives (sphere, cone, cylinder) which will 
connect the two parts together. For that we will need a nice view to point the pins  
on  the  model.  Here  we  are  also  using  the  shaded+wireframe  view  mode 
available with the         icon. 
Let's start. First rotate the model, erase the screen and display the lower part 
of the dino, shell 2. b-DinoOk (Split). Zoom in to the front end of the model to 
be able to accurately position the connectors with the next command.
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The pins are now created with the Print Preparation > Connect command or 
using the Print Preparation Tab shortcut

After the command is given, it is possible to give the shape and the size for the 
pin to be created. The software computes default values based on the model 
bounding box when use default (1/10 of max ext) is set. Now set Diameter and 
Length both to 10.0, as seen below: 

The pins are positioned with LMB clicks on the display area on top of the dino 
model. Give two locations, the positions for the red conical pin location indicators 
should look similar to the image below when set. Note that you can use the MMB 
zoom and MMB rotation to change the view point when locating the connectors. 
If a connector location is not correct you can remove it by clicking on the red 
indicator  cone  again.  Then  reposition  with  another  LMB click  on  the  correct 
location. 
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When ready Press OK to generate the connectors. After a while you will see 
the connectors added to the selected shell (in shaded mode again with      icon): 

Corresponding holes are automatically created to the a-DinoOk-connector shell.
 

Transferring the result for 3D Printing

You can save both files into the same STL file by selecting the Model Tree root 
All. Anyhow, you normally wan to build and position the parts separately in the 
3D Printer. For that select each shell separately and output it to a proper STL file 
with File > Save As command.  
If you wish to save the two parts into one file, you should move the shells apart 
from each other with the Transform or Print Preparation > Move Platform menu 
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commands prior to outputting the model for 3D Printing. To output one file, select  
the Model Tree root All before the Save As command. 
Also, if you wan to use the Print Preparation menu plugins to transfer the tow 
halves directly to another AM application, like some 3D Printer control software, it  
is good to position the halves correctly before the plugin execution. 
To define and use plugins from DeskArtes software products, please see On-line 
Help Menus and Commands  > Print Preparation > New Plugin page. This page 
explains how to create connection to 3D Systems ZPrint, Stratasys CatalystEX 
and Objet Studio software products, for example. 
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Further Reading 
This Quick Start Guide has given you the skills to verify and repair models with 
moderate or  few errors for 3D Printing.  Also,  model  splitting for  building with  
systems with smaller build areas when compared to the part size is presented. 
Repaired data transfer to further processes is explained. 
This Quick Start Guide is the first in a set of tutorials covering different aspects of 
model  repair,  coloring and print preparation. The tutorials are available in the 
software distribution package through the Help > Tutorial Documents menu: 

● Expert Series 10.0: Quick Start Guide  gives a short introduction to model 
repair and splitting for 3D Printing with 3Data Expert, 3Data Expert Lite 
and Dimensions Expert products. Estimated completion time 15 minutes.

● Expert Series 10.0: Tutorial 1 – Working with 3D Models introduces basic 
viewing,  measuring,  automatic  repair,  split,  connect,  hollow,  offset,  3D 
Text,  Boolean,  cut,  reduce,  surface  triangulation  and  other  model 
manipulation functions available for STL files. Applies to All Expert Series 
modules. Estimated completion time is 3 hours. 

● 3Data  Expert  10.0: Tutorial  2  –  Working  with  Colors  introduces  basic 
automatic repair and coloring for 3D Color Printer users. For 3Data Expert 
only. Estimated completion time is 60 minutes. 

● Expert Series 10.0: STL and VRML repair examples document includes 
more  advanced model  repair  operations with  3Data  Expert.  Applies  to 
3Data Expert module and mostly to 3Data Expert Lite, Dimensions Expert 
and Sim Expert modules. Estimated completion time with 3Data Expert 2 
hours. 

More information and other STL manipulation tools can be found in the Handling 
Faceted  Models  section  of  the  On-line  Help  pages.  These  pages  contain 
information on model  verifying,  repairing, splitting, offsetting and hollowing for 
Additive Manufacturing. 
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